admin

CCNA Basit Komutlar Kendi Anlayacağım Şekilde :)

Merhaba,

Cisco switch ve routerlarda kullandığımız temel komutları ve ne işe yaradıklarını kısaca özetleyeceğim.

 

1.Switchlerde güvenlikten bahsedecek olursak önce banner nasıl eklenir ondan bahsedelim

global configuration moda girdikten sonra yazılması gereken komut aşağıdaki gibidir. Bu komutu yazarken dikkat edilecek husus komutu yazdıktarn sonra #işareti ile başlayıp #işarati ile bitmesi gerekir

#conf t

#banner motd #**********izinsiz girişler yasaktır***********#(motd=message of the day)

#banner login $izinsiz girme$

 


 

 

 

2.Switchlerde komut yazmadan önce komut yazımını kolaylaştırmak için ekrana gelen loğların komut yazmamıza engel olmaması için yapmamız gereken configurasyon aşağıdaki gibidir.

 

#conf t

#line console 0

#logging synchronois

 

3.Switchte yanlış bir komut yazıp enter tuşuna bastığımız zaman domainden yazılan komutu çözmeye çalışıyor bu arama yaparken vakit kaybı olmasın istiyorsak aşağıdaki komutu yazmamız gerekiyor.

 

#conf t

#no ip domain- lookup

 

A—Bağlantı zaman aşımına uğramasın istiyorsak komut ****Burda dikkat edilmesi gereken husus uzun süre bağlantı time out olmasın evet ancak başka insanlarında sürekli bağlandığı ve sessionı sonlandırmadan çıktığını düşünürsek belli bir zaman sonra kimse bağlanamayacaktır.

 

#conf t

#line console 0

#line exec time out 0

 

4.Switchlerin güvenliğini sağlamak için telnet şifresi vermek ve telnet şifresinin criptolanmasının nasıl yapılacağını aşağıdaki komutlarla gerçekleştiriyoruz.

 

#conf t

#line vty 0 15 =>bu komut taki vty telnet anlamına gelir ve 0 15 portlara telnet ile bağlanabilri 15 kişi

#password cisco

#login

sonra exit

#conf t

#service password encription=>bu komut artık criptolu olarak gözükecek bizim şifreler

 

5.Switche enable şifre verilmesi

 

#conf t

#enable secret cisco=>passsword cisco dersek şifre gözükür.

 

6.#terminal lenght 45 =>sh run dediğimizde kaç satır ekranda göreceğiz onu belirler.

 

7.Vlan tanımlama ve isim verme

Vlan tanımlamadan portlara vlan atama yapılmaz.

 

#conf t

#vlan 12/

#trunk allowed vlan add 34

 

13. interfacelere vlan eklerken range kullanımı

#conf t

#interface range fastethernet 0/3-14, fa 0/7

#switch port mode Access

#switch port Access vlan 2023

 

14. Native vlan değiştirme önemli: iki switch birbirine bağlarken native vlanları aynı olmalı.

#conf t

#inter fas 0/1

#switch port trunk native vlan 100

*******dtp kapatmak***** yani dinamik trunking protokol başlangıçta switch te açık gelir.

switchport nonegotiate

 

15.Sub interface oluşturmak. Routerda oluşturulan interface e ip vermemek gerekir.

#conf t

#inter fas 0/0.44 burdaki 44 istediğin bi değer olabilir.

#encapsulation dot1q 44 =>burada hangi vlana izin vermişsek onu belirtiyoruz.

#ip address 10.1.1.1 255.255.255.0=>izin verilen vlan

 

16. DHCP oluşturma

önce routerda

conf t de

ip dhcp pool vlan 44

default router 10.10.4.1

network 10.10.4.0 255.255.255.0 burda kaç adet ip dagıtacagını söylüyoruz

lease 0 2 dhcp adresinin ne kadar kiralanacağını söylüyor 0 gün 2 saat

 

clientta girilecek komute

conf t

ip address dhcp

 

sh ip dhcp biending hangi maknalara ip dağıtmış.

 

 

17.ssh oluşturma

#conf t

#ip domain name fatih.com

#crypto key generata rsa

1024 seç

sonra

line vty 0 15

transport input ssh

login local

exit

ip ssh version 2

 

conf t

username fatih secret cisco

 

 

 

başka makinadan ssh çekmek

ssh -l kullanıcı adı ip address

ör

ssh -l fatih 10.10.1.3

 

18 port- sec

ne işe yarar hemen söyliyim

switchin mac adresine göre erişimi engelle veya izin ver.sud

switchin interfaceine gir

switch port port security enter

switch port port security maximum 1 =>1 kişi bağlansın

switch port port security mac-address sticky=>burada çakılı olan portun mac adresini buraya ekle

switch port port security violatin shutdown>başka mac adresi bağlanırsa port down olsun

 

19.Access list standart tanımlama

conf t

ip access list standart fatih

standart source ip verebiliyoruz

 

extendat ta hem port hem ip ye bakıyor.

conf t

ip access list extendet fatihtelnet

deny tcp any any eq 23

permit ip any any?>burdada telnet dışındakilerin hepsine izin ver demek

sonra bu oluşturduğumuz acl i

nereye uygulayacağımızı seçip örnegin routerin iç bacagına yada dış bacagına

inter fas 0/0 c

ip access group fatihtelnet out

 

20. ospf tanımlama

router in interfacinde

ip ospf 1 area 0

 

sh ip ospf nei=ospf komşularını gör

clear ip ospf process =ospf restart ediyor.

hatalarda debug ip ospf event

fa

 

 

 

 

21.ipv6 outoconfig yapınca karşı taraftan networkü ögrenmesi gerekiyormuş.

ipv6 unicast routing

ipv6 address 2001:a1b2:1000:1111::44/128

 

 

s

22.Spening tree oluşturmak

vlanı oluştur ve komşu switchlerle trunkları oluştur.

show spanining tree vlan 4 root primary=>burada vlan 4 üzerinden root edecektir.

manuel olarak speninng tree oluşturduk.

show spanining tree vlan 4 ile de izle

 

Switchler priorty değerine göre rout bridge seçer.

Normalde tüm switchlerin priorty değeri aynı gelir ve aynı priorty değerine sahip switchlerde root bridge mac adresi küçük olan switch tir.

Kimin root switch olduğunu :sh spenning-tree  komutu ile görebiliriz.

 

23.İnterface range fastethernet 0/7 – 8

channel-group 1 mode active=lvcp  uluslar arası standart protokolu active

exit

interface port-channel 1  =>sanal interface de grouplama yapıyoruz. ve buradaki port channel 1 aslında 7 ve 8 i kast ediyor

switch port mode trunk

switchport trunk allowed vlan 1,2,10

 

kontrol

sh etherchannel  port chann summerysw

 

24.Port fast olayı

Burada switchin bağlanacağı bacaklara sadece pc prinnter bağlansın ve çok hızlı açılsın istiyorsak.

interface in o bacağına girip

spaning tree portfast

spaning tree bpduguard enable =switch bağlanırsa portu shut et

 

 

25 EIGRP yapılandırması

routerin ilgili interfacelerine

conf tl

router eigrp 100 =burdaki yüz ospf deki area gibi her yerde 100 olması gerekir

network 10.1.1.0

network 192.168.2.0

 

sh ip eigrp neighbors= komşuları gör

sh ip eigrp interface =hangi interfacelerde eigrp çalışıyr.

sh ip eigrp topoloji= burada a görürsek o yol çökmüş p ise sıkıntı yok

sh ip route=yolları ögreniriz d ise eigrp ile

 

router eigrp 100

passive interface loopback   bu iki komutla eigrp brodcastini engelliyor yada buna benzer bişey.

 

interface in altında variance 4 diye bir deger girdiğimizde eigrp yapılandırmasında normalde bandwithi en yüksek olan yerden gitmesi gerekirken burda laod balance yaparak iki hattı da kullanırı.

 

26.Önemli bilgi interface i sıfırlamak içinen

conf t

default interface fas 0/1

 

 

27.ipv6 eigrp config

önce interfaclere ipv6 ver

elle ip verdim ben

ipv6 unicast routing

ipv6 address 2001:a1b2:1000:1111::44/128

conf ta ipv6 router eigrp 1

no shot

sonr interfacin altında

ipv6 eigrp 1

no shotdown

 

28 Loopback oluşturma

inter loopback 1

ip addess 10.10.10.1 244.2444.244.0

 

 

29  OSPF Muti area yapılandırma

conf t de

router ospf 1

network 10.0.16.0 0.0.0.255 area 0 =burda önemli olan arealar

 

 

30.WAN yapılandırma ppp ve chap yapılandırma

routerlar arasında haberleşmek için kullanılan protokollerdendir

serial interfacelerde yapılır bu  güvenli bağlantı için

leass line bağlantı isp lerden kiralanan hatlar için geçerli dir bu bağlantı

burada config yaparken

conf t de

karşıdaki routerin username ve şifresini girerirz

username r1 password cisco

sonra seri bağlantı için

inter seria 0/0/0

encapslation ppp

ppp authentication chap=burda güvenli chap bid e pap var

yine config if altında clockrate 128000 falan verilmesi gerekiyor ancak biz dce isek verebiliyoruz clokrate i dte veremiyor komutu ise

bid e bandwith vermek gerekior komut bancdwitdth 512 burda da cost hesabı gbii düşünüyoruz.

 

show cdp nei borda komşularını görmen gerekiyor ve bu yapıyı yaparken aynı network de olması lazım 2 routerin

sh conterllers serial 0/1/1 dende interfacein durumunu görebiliyoruz.

debug ppp authentication la da durumu görüntülüyoruz orda en altta seccess se işlem tamamdır. zaten sonra debug kapatmak için

undebug all

no debug ppp authentication demek gerekiyor.

sh controllers serilal 0/1/0 ile clockratei kim vercek onu ögreniyoruz örnegin   DCE ise clockrate vercem

DTE olsaydı clockrate karşısı vercek.

 

ppp =uluslar arası sh inter serial dan encapsulation tipine bak olmuş mu diye

hdlc =cisco protokol

 

İp helper address 10.0.16.20 dediğimizde bizim dhcp adresimiz başka bir vlandaysa o interfacein altına eklyoruz.

 

Herhangi bir switche consol kablosu ile bağlandığımız zaman bu switche bir ip vermemiz elzemdir.

Daha sonra bu ip den telnet ile bağlantı yapabilmek için.

 

31.

Pat

r1(config)#access-list 1 permit 10.10.10.0 0.0.0.255  //nat yapacagım ip yi seçtim

r1(config)#access-list 1 permit 10.20.20.0 0.0.0.255

r1(config)#interface fastEthernet 0/0.10//hangi interface inside sa onu belirledim

r1(config-subif)#ip nat inside

r1(config)#interface serial 0/0

r1(config-if)#ip nat outside //hangi bacak outside onu belirledim

r1(config)#ip nat inside source list 1 interface serial 0/0 overload//belirlediğim interfaceleri uyguladım overload fazla yükle dedim

 

ping atıp aşagıdan kontrol ediyoruz

 

sh ip nat tra

 

 

 

 

İnterface sıfırlamak için;

default int fa 0/1

 

 

997.Routerda işe yarar Show komutları.

—-sh cdp status =>router komşularını gösterir.

 

998.Swithcte çalışan Show komutlarıf

 

—-#sh vlan=>vlanların durumunu gösterir.

 

—-# test cable-diagnostics tdr int fa 0/1 sonra da   sh cable-diagnostics tdr int fa 0/1=>kablonun uzunluğunu gösterir.

—-#Show cdp neigbors=>switchin komşularını gösterir.

—-#Show ospf neigbors=>ospf komşuları görmek için

—-#sw inter trunk =>trunk portları gösteriyor.

 

 

 

999.İngilizce kelimeler ve anlamları.

—-%incomplate commond =eksik komut anlamındadır.

—-%invalid input^=işaretli olan yer geçersiz giriş yanlış karakterdir.

—-%ambigous command =belirsiz geçersiz komut

—-unassigned =atanmamış demek.

—-administratavaliy down yönetimsel olarak kapalı demek.

—-Unklown =bilinmeyen

—-Half dublex=sadece 1 taraf veri gönderebilir.

—-Full dublex=her iki port ta veri gönderebilir.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Be Sociable, Share!

2 thoughts on “CCNA Basit Komutlar Kendi Anlayacağım Şekilde :)

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir